Copy'n'paste rückwärts?

Fehler der Release-Versionen
Antworten
frank42
Beiträge: 7
Registriert: Mi 3. Jul 2019, 14:43
Danksagung erhalten: 1 Mal

Copy'n'paste rückwärts?

Beitrag von frank42 » Do 4. Jul 2019, 12:22

Hi,

ich nochmal. Ich habe da was ganz komisches festgestellt. Wenn ich aufgrund der Länge der Accountnamen versuche, diese per Maus einzufügen, gibt es einen ganz komischen Effekt. Es wird beim paste rückwärts eingefügt, warum auch immer. Das sieht zum Beispiel dann so aus:
Screenshot_2019-07-04_12-17-58.png
Screenshot_2019-07-04_12-17-58.png (115.94 KiB) 81 mal betrachtet
Wenn ich also z.B.

Code: Alles auswählen

/listaccounts
per Maus kopiere und reinpaste, kommt

Code: Alles auswählen

/stnuoccatsil
bei raus.

Probiert unter Gentoo Linux mit xfce-terminal und dem klassischen xterm, beides mit TERM=xterm und TERM=xterm-color probiert, gleicher Effekt.

frank42
Beiträge: 7
Registriert: Mi 3. Jul 2019, 14:43
Danksagung erhalten: 1 Mal

Re: Copy'n'paste rückwärts?

Beitrag von frank42 » Mo 5. Aug 2019, 12:25

Nur für den Fall der Fälle: die Meldung ist ernst gemeint, ich kann auch gern ein Screencast Video davon machen :-)

Benutzeravatar
Robin
Administrator
Beiträge: 1544
Registriert: So 30. Jun 2013, 18:12
Wohnort: Rheinland-Pfalz
Hat sich bedankt: 248 Mal
Danksagung erhalten: 225 Mal

Re: Copy'n'paste rückwärts?

Beitrag von Robin » Sa 10. Aug 2019, 10:09

Hi Frank,
tatsächlich bist du nicht alleine, das Problem habe ich letztes Jahr schon festgestellt, konnte aber noch nicht herausfinden, woran es liegt.
Interessanterweise passiert es unter der Windows-Konsole nicht, muss also entweder an Mono liegen oder irgendwas mit den Linux Shells.

Wir haben das aber noch auf dem Schirm, danke für die Meldung.

Grüße,
Robin
MFBot-VersionCode-Zeilen*In Dateien*Letzte Version
MFBot 1.5.x64851Juli 2013
MFBot 2.x1436316März 2014
MFBot 3.x2209536März 2015
MFBot 4.x55242241Juli 2018
MFBot 5.x72000378Tbc
*Ohne automatisch generierten Designer-Code

frank42
Beiträge: 7
Registriert: Mi 3. Jul 2019, 14:43
Danksagung erhalten: 1 Mal

Re: Copy'n'paste rückwärts?

Beitrag von frank42 » Mo 14. Okt 2019, 12:14

Moin,
keine Ahnung ob das weiterhilft, ich bin leider nicht so der crack was traces lesen angeht, aber das hier hab ich mal mitgeschnitten:
[Gegeben: aktuellen mfbot gestartet, dann die eingeloggten Accounts mit /pause ruhig gestellt, dann aus anderem Fenster den string "pizza.de" markiert und per mittlerer Maustaste ins mfbot Fenster kopiert]

Code: Alles auswählen

[...]
25762 futex(0xa14d88, FUTEX_WAIT_PRIVATE, 0, {tv_sec=0, tv_nsec=499999567} <unfinished ...>
25757 <... read resumed> "pizza.de", 1024) = 8
25757 write(1, "p", 1)                  = 1
25757 select(1, [0], NULL, NULL, {tv_sec=0, tv_usec=150}) = 0 (Timeout)
25757 write(1, "i", 1)                  = 1
25757 write(1, "\33[?25l", 6)           = 6
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "                                "..., 116) = 116
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "pzi", 3)                = 3
25757 write(1, "\33[34;3H", 7)          = 7
25757 write(1, "\33[?12l\33[?25h", 12)  = 12
25757 write(1, "\33[?25l", 6)           = 6
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "                                "..., 116) = 116
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "pzzi", 4)               = 4
25757 write(1, "\33[34;3H", 7)          = 7
25757 write(1, "\33[?12l\33[?25h", 12)  = 12
25757 write(1, "\33[?25l", 6)           = 6
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "                                "..., 116) = 116
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "pazzi", 5)              = 5
25757 write(1, "\33[34;3H", 7)          = 7
25757 write(1, "\33[?12l\33[?25h", 12)  = 12
25757 write(1, "\33[?25l", 6)           = 6
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "                                "..., 116) = 116
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "p.azzi", 6)             = 6
25757 write(1, "\33[34;3H", 7)          = 7
25757 write(1, "\33[?12l\33[?25h", 12)  = 12
25757 write(1, "\33[?25l", 6)           = 6
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "                                "..., 116) = 116
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "pd.azzi", 7)            = 7
25757 write(1, "\33[34;3H", 7)          = 7
25757 write(1, "\33[?12l\33[?25h", 12)  = 12
25757 write(1, "\33[?25l", 6)           = 6
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "                                "..., 116) = 116
25757 write(1, "\33[34;1H", 7)          = 7
25757 write(1, "ped.azzi", 8)           = 8
25757 write(1, "\33[34;3H", 7)          = 7
25757 write(1, "\33[?12l\33[?25h", 12)  = 12
25757 select(1, [0], NULL, NULL, {tv_sec=0, tv_usec=150}) = 0 (Timeout)
25757 read(0,  <unfinished ...>
25762 <... futex resumed> )             = -1 ETIMEDOUT (Connection timed out)
Mir sieht das ein wenig so aus, als wäre die Ursache in den escape characters der Farbgebung zu suchen. Leider lässt sich der bot aber nicht mit ohne bunt starten, wenn ich als terminal ein vt100 angebe, krieg ich nen Fehler um die Ohren geworfen und ne Option zum deaktivieren der Farbe gibts ja leider auch nicht :-)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste