Magical Fidget Bot – Version 3.2.x [Release]

Guten Morgen zusammen!

Wir freuen uns euch mitteilen zu können, dass die Version 3.2 in den Startlöchern steht!

In dieser Version sind wieder eine ganze Menge Fehler beseitigt worden – ein Update ist also ratsam.

Noch ein kleiner Hinweis zum Thema Spenden: Paypal genehmigt sich für ihren Service neben den üblichen 2% noch einen festen Posten von 0.35 Euro – spart euch also bitte die Mühe, Beträge zu spenden, die unterhalb dieses Levels liegen.

Version 3.2.1: 

~+ Gold/Silber-Anzeige auch zum Charakter-Tab hinzugefügt.
# Einige Übersetzungen hinzugefügt.
# Bot geht beim Bierkauf jetzt nicht mehr unter das Pilzminimum.
# Anzeigefehler im 3a-Fenster behoben (Alle Accounts ändern).
# ALU-Anzeige (gesamt) wird nach Bierkauf jetzt automatisch aktualisiert.
# Bei Raids fehlte im Chat der Ausgang.

Version 3.2.0.1: Fenster lässt sich wieder schließen.

Changelog von 3.1 auf 3.2 (*):

+ Synchronisationsmöglichkeit der SID durch Rechtsklick hinzugefügt.
Folgendes Szenario ist also jetzt möglich:
1.) Du hast dich wegen etwas wichtigem im Browser eingeloggt, dir fällt aber auf, dass bspw. die Quest gerade endet – ergo, der Bot loggt dich aus
2.) Du gehst in den Bot, klickst auf den Account mit der rechten Maustaste, dann wirst du aufgefordert dich einzuloggen und auf „Charakter“ zu drücken
3.) Du loggst dich im Browser wieder ein, klickst auf „Charakter“ und der Bot zeichnet die SID auf
4.) Der Bot übernimmt die SID und arbeitet fortan mit der SID, die der Browser auch benutzt
–> Kein Logout/Login-Gedöns mehr notwendig 🙂

~ In der Spalte für Abenteuerlust wird jetzt auch die maximal verfügbare Abenteuerlust angezeigt (im Stil X / Y)
~ Passiv-Modus eingeführt, in den der Bot geht, wenn es nichts mehr zu tun gibt.
In diesem Modus verbleibt der Bot eine Stunde, und schaut dann, ob wieder etwas möglich ist. Arena, Dungeons und Turm sind davon ausgenommen.
~ Im „Starte/Stoppe Aktion“-Eingabefeld ist jetzt der Standardwert wieder „0“
~ SMART-Funktion: Zeitquestauswahl geht jetzt auch in die Durchschnittsberechnung ein, EP-Events werden auch beachtet
~ SMART-Funktion: Reset der Werte nach jedem Level-Up anstatt alle 10 Quests.

# Tavernenbug gefixt
# Gildenausbau blockiert den Chat jetzt nicht mehr
# Nach (manuellem und automatischem) Blättern wird jetzt wieder angezeigt, wenn keine Flasche verfügbar ist.
# Bot geht jetzt nicht mehr in die Arena, wenn diese nicht aktiviert ist.
# Dungeonfunktion bei vollem Inventar gefixt
# „Verkaufe teuerstes/billigstes Item“-Funktion gefixt: Die teuersten Items werden wieder richtig verkauft und die auszuschließenden überhaupt nicht mehr
# Bug mit ausländischen Servern behoben
# Einige Übersetzungen des GUIs hinzugefügt
# Bei nicht genügendem Gold für Flaschenkauf wird jetzt auch eine entsprechende Meldung angezeigt, nicht mehr die Meldung „.. würde angegebenes Minimum unterschreiten“
# Händler-Tab bei ‚Alle bearbeiten‘: Text bei Pilze/Gold passte nicht
# Manueller Flaschenkauf geht jetzt ohne Gold- und Pilzminimum
# Reittierbug gefixt
# Tavernenfehler gefixt
# Sprachbugs gefixt
# SMART-Funktion: Werte werden jetzt gerundet.
# SMART-Funktion: Bug beseitigt, der zur dauerschleife des Fehlers +E078 führte (passierte wenn die Erfahrung kleiner als die durchschnittl. Erfahrung war und dann 2 Quests gleich kurz und gleich viel Exp/s gaben)

– „ALU leer“-Meldung entfernt

Downloadlinks:

Und wie immer gilt: Um das Update zu “installieren”, die alte Datei einfach durch die neuere ersetzen. (Tipp: Acc.ini vorher sichern :))

Sprachpaket Englisch / Language pack english

Download (Unzip the en.zip in the directory of the MFBot)

+ = Hinzugefügt
~ = Geändert
– = Entfernt
# = Bugfix


[PU_BotProgramupdate_Invisible]3.2.1.0[/PU]

85 thoughts on “Magical Fidget Bot – Version 3.2.x [Release]
    • Hallo Markus,
      hattest du den Ordner „db“ denn mal gelöscht, nach dem einen Hinweis eines Users?

      Grüße,
      Robin

      • When we delete the content of db folder bot seems to work more „fast“ and without stacking problems …

        In an other occation on the bot of a friend this „delete“ seems to fixed his problem with the non working status!

        Best regards
        Red

  1. Hi there,

    I got another fehler when it is going to city guard for the night.

    Code +193

    Can you fix this?

    Greets Erwin

    • I think that they are working on it 🙂

      When you face that press „Manually stop action“ button and then „Manual start action“ … that works for me when i face the 193 error code …

      Best regards
      Red

  2. Tach,

    erstmal danke für den Bot, der ist richtig gut gelungen. 🙂

    Aber habe da mal ne Frage, kann ich irgendwo einstellen, dass der Bot bei den Arena kämpfen nur bestimmte Gegner angreift, also ich z.B. in der Acc.txt ich das irgendwo eingeben kann?

    Beste Grüße
    theoverprogamer

    • Hallo theoverprogamer,
      momentan ist das noch nicht möglich, eventuell werden wir dafür aber in der neuen Version eine Einstellung in der Acc.ini anlegen, sodass es manuell möglich ist.

      Grüße,
      Robin

  3. Hello MFbot Team :)) !

    Here is another issue !

    Clock is on 00¨00 hour and according to the bot it’s time for arena …

    Bot finds player … battle is done …

    Normaly the character should enter tavern and pick up a quest! But no … bot put the char into 10 hour city guard (solution … stop action manualy from the bot … and start the action manually … and char plays his quests)

    Any ideas ?
    Thanks in advance

    Best Regards
    Red

      • Many thanks for yor answer my friend!

        Thanks in advance for your efforts to support us!!!

        Best regards
        Red

    • Hi Redbeardcat,
      do you receive this error all the time or only sometimes?

      Regards,
      Robin

      PS: It’s possible that we fixed the error already, in this case we can’t comprehend the error 🙂

      • Hello and many thanks for your answer!
        I’m receiving this error after the character has finish the tavern time (and the extra one beer) and he enter the arena before start the hourly city guard.
        The bot select opponent … battle is done … and then nothing … bot cannot put city guard and do nothing !

        Best regards
        Red

  4. Hallo Team,
    ich kann den Bot nicht mehr öffnen da seit 20 Tagen nichts mehr gemacht wurde.
    Kommt da noch was oder habt ihr aufgehört

    • Hallo Amon,

      ich kann dir versichern, dass wir nicht aufgehört haben – wir werden uns nicht alle 2 Wochen melden, nur damit es ein Lebenszeichen gibt.
      Im Forum sieht man, dass wir noch aktiv sind 😉
      Das lange kein Update mehr kam hat den Grund, dass wir momentan an einem großen Update arbeiten 😉

      Grüße,
      Robin

        • Versuche mal den Inhalt des „db“ Ordners zu löschen – das hat bei mir geholfen als der Bot nicht mehr lief.

  5. Angeblich wurde der Bot erkannt und schon Profile aufgrund von dem Bot gesperrt, man sollte den Bot vllt nicht ganz so populär aufziehen ^^

    • Hallo Markus,

      in deinem Kommentar fehlt die Angabe der Quelle 😉 Bitte keine unbelegten Gerüchte verbreiten!

      Beste Grüße,
      Olafson

    • Hi Markus,

      Bisher gibt es noch immer keine Anzeichen dafür das Playa den Bot erkennt,
      allerdings kam es durch unglückliche Einstellungen einige Anwender (Arena Zeitintervalle etc.) schon dazu das der Bot recht auffällig gespielt hat. Wenn die Arena punktlich alle 10 Minuten durchgespielt wird über einen längeren Zeitraum ist das natürlich recht auffällig 😉

      Aber keine Panik, wir arbeiten permanent daran den Bot unaufälliger und ‚Menschlicher‘ werden zu lassen 🙂

  6. I downloaded this bot for the first time, clicked twice on the icon and nothing happens ( I also tried with „run as administator)… I downloaded also the older versions and there is error : „Magical Fidget Bot stopped working“ … I have NET Framework 4.5 installed… Sorry for English I barely understand German…

    • Seems that it could need some investigation to solve your problem. Please register to the forum and ask there for help again!

      Best regards,
      Olafson

  7. Possible to get english version? cus in options i change to english, and nothing happens :/

  8. Mädels, eure neue version buggt und die alte darf man nicht mehr nutzen. Wollt ihr euch eigentlich mit einer deartigen gängelung bei EA bewerben?

    unschön. und das argument mit dem supporten lasse ich auch mal nicht gelten.

    • Denkste, das hab ich nicht schon gerafft?

      Und denk mal nen bissl über deine Wortwahl nach…

      Unfreundliches etwas…

    • Hast du Geld dafür gezahlt? Nein! Keiner zwingt dich den Bot zu benutzen. Kannst ja gerne selber einen schreiben – natürlich ohne dafür bezahlt zu werden. Das ist ein FREIZEITprojekt….dass da nicht jeden Tag eine neue Version rauskommt sollte jedem klar sein.

      Meine Version läuft, seit sie raus ist, problemlos…..

    • Manchmal bin ich froh, dass das nur ein hobby-projekt von uns ist, und wir deshalb Antworten können was uns so durch den kopf geht. Also:

      Warum verschwendest du dein und unsere Zeit, indem du so einen unqualifizierten kommentar schreibst? In der selben Zeit hättest du etwas produktives tun können wie z.B. die bugs zu reporten, von denen der Bot ja nur so zu strotzen scheint; oder für die Schule lernen können; oder Sport machen; oder von mir aus auch nur in der Nase bohren, all das wäre um ein vielfaches sinnvoller gewesen…

      MfG
      Licor

  9. Hi Leute,

    hoffe, es kann jemand helfen! Seit einigen Tagen funktioniert der Bot bei mir vom einen auf den anderen Tag überhaupt nicht mehr 🙁 Hab Windows 8.1, 64bit. Hab meines wissens auch keine Einstellungen in Windows oder sonstwas geändert. Wenn ich den Bot anklicke, verwandelt sich der Mauszeiger nur kurz in sein „Ladekreiszeichen“, aber es öffnet sich gar nichts. Nichtmal die Oberfläche. Hab schon versucht, die Datei erst komplett zu löschen und dann neu runter zu laden, aber auch das bringt nichts. Hat jemand ne Idee, was es sein könnte?

    • Mir geht es genauso und ich hab Windows 7 Home Premium…

      Naja, mal schauen was da los ist 😀

      • Habs grad probiert, aber dann kommt die Meldung, das der Bot nicht mehr Ausgeführt werden kann und dann schließt sich alles 😡

        • Ich könnte jemandem den Crash-Log zukommen lassen. Ich selber kenn mich da leider nicht so mit aus. Aber vielleicht lässt sich daraus ja was auslesen?

    • Hallo zusammen!

      Ich tippe mal auf die Acc.ini, die schon mal gerne der Verursacher solcher Probleme ist. Denn der Bot schreibt immer mal etwas da rein und das kann schon mal schief gehen…

      Also am besten die derzeitige Acc.ini durch eine alte, funktionierende ersetzen (z.B. aus einem Backup) oder die Acc.ini umbenennen, z.B. in ‚Acc.ini_defekt‘ und die Chars noch einmal neu anlegen!

      Hoffentlich hilfts!
      Olafson

    • Bei mir wollte der Bot auch mal nicht mehr laufen….In meinem Fall hat es geholfen den Inhalt des „db“ Ordners zu löschen. Warum das so ist/war wäre aber mal interessant herauszubekommen.

  10. ich weiß schon langsam nicht mehr weiter bei mir will es einfach nicht funktionieren es macht weder quest noch tränke kaufen oder Reittier gar nichts macht er nur gilden kämpfe anmelden was mache ich falsch bitte hilft mir 🙁

    • Hallo Sasuke,

      das hört sich ja nicht gut an!

      Die Einstellungen, also das kleine Zahnrad unter der Liste mit den Chars hast Du aber schon gefunden, oder? Dort kannst Du alle Sachen beeinflussen, die der Bot machen soll. Bei allen Optionen, die ausgeführt werden, ist das entsprechende Kästchen markiert. Damit er zum Beispiel auf Reisen geht, musst Du die Option aktivieren und dann noch festlegen, ab welcher Uhrzeit er damit anfangen darf. Standard ist hier 08:00 Uhr.

      Sollen mehrere Chars auf einmal geändert werden, geht das über ‚Alle bearbeiten‘. Dabei muss dann aber zuerst die jeweilige Kategorie aktiviert werden und dann lassen sich die entsprechenden Optionen innerhalb dieser Kategorie anpassen.

      Ich hoffe, das hilft Dir etwas weiter!
      Gruß, Olafson

      • erstmal danke für deine hilfe also das mit Quest habe ich schon hin gekriegt er kauft nur nicht tränke oder Reittier die machen bis jetzt Probleme

  11. Helloes!

    First let me say you guys did an amazing job, the bot works mostly bugfree! However there are some problems (at least for me) that I’d like to report:
    – Sent a few email already, yet my donator status is still false… (Yes, I did donated, see the next sentence)
    – I’m still getting 2 different HWID aswell after a couple of restarts and nothing changes in my computer afaik (Throw me an email where to send the 2 different hwid pics so maybe you can figure out what’s happening)
    – The latest english file is just not working for me had to switch back the previous resource file
    – Start with Windows throws an exception if I start the bot minimized (system: win8 x64, both version of the bot does the same)

    Sorry for the english language, I barely understand german…

    Thanks for your help and for your amazing work!

    • Hi Frost,

      English is ok, better than an automatic translation 😉

      I guess, you are using the 32 bit version of the bot? This one we did not cross check and you are right, it still shows only the German text 🙁

      Regarding the HWID send all of them to Robin, it doesn’t matter ^^

      Best regards,
      Olafson

  12. Hello!

    First of all many thanks and BRAVO’s for your excellent work!

    I have a problem with the bot regarding the language. I ve download the zip file and placed his content to the mfbot dir but i still cannot change tha language to english although it appears in the dropdown menu as a selection. I apply the setting but still nothing. Any ideas ? Its not such a big matter but if there is any solution it would be nice 🙂

    Another thing is that the bot to one and only character (in a set of 10 characters) throw to the toilet every item that he find to the quests even if its an epic, In every other character the toilet work just fine! (the configuration is the same to each one of them).

    Last thing with example …

    Character have 26 mushrooms before starting the daily quests …
    Setup to bye 3 beers per day …
    Set up to keep min 25 mushrooms …
    Character earns only the default mushroom of the first quest and no more.

    Result after the quests (100 min + 3 beers) … character with 24 mushrooms in his pocket …
    Normaly it should be … quests (100 min + 2 beers) … character with 25 mushrooms in his pocket

    Any ideas ?
    Thanks in advance!

    • Hi Erwin!

      First of all thank you for the positive feedback and also the bug report ^^

      The language error is always present because of GUI changes.
      Nevertheless it is fixed now – feel free to use it with the current version of the bot (v321). Download and replace only the language pack.

      The ‚mushroom bug‘ has already been fixed (avaliable with the next version). The bot will keep the exakt minimum then – currently it stops one mushroom below.

      Regarding the use of the toilet I have no idea, sorry. Maybe you are able to figure out, what happens there and report on it. Also you could try to separate the char in an extra Acc.ini and try to reproduce the error again. If so, you could send that ini to Robin and help to fix the bug this way.

      Best regards,
      Olafson

  13. Good morning,

    Good job for the new version.

    It looks very good.
    Only thing that is not working is the city guard for 10 hours. My quests are done between 8 and 20 and city guard works perfect for one hour the time, but after 20 pm, it won’t go on 10 hour city guard for the night.

    Is there a solution for this problem??

    Greetings Erwin

    • Hi Erwin,

      did you set also ‚don’t quest before‘ to something reasonable, e.g. 8:00 o’clock? This is important for the night watch 😉

      Hope this helps and is something trivial like this – because the error didn’t show up elsewhere!
      Olafson

      • Hi Olafsen,

        it is set like no quests before 8 en I set the quests between 8 and 20.30.
        But still it doesn’t work for the night.

        Should I sent a copy of the account file to you?

        When I us the old bot, it works, but with this version, it doesn’t?

        • Erwin, you could register to the forum and send a message with the Acc.ini to me. If possible generate an ini with just one char in it that still shows the problem!

          Best regards,
          Olafson

          • Hi Olafsen,

            sorry for the late response, been busy for a while.
            çan you send me your mail adress?

            I can’t PM on the forum .

            Greetings erwin

  14. Der bot funktioniert bei mir nicht richtig. Nach dem starten macht er 2 Quest und dann gar nix mehr. Es kommt auch keine Fehlermeldung. Habe jetzt wieder den 3.1.0.0 genutzt und der läuft tadellos. Leider ist die Benutzung des 3.1.0.0 nur noch 19 Tage möglich.

          • bei Gold hat es funktioniert, probiere es morgen wieder mit xp und werde berichten

            • hab es heute wieder mit xp probiert und es trat der selbe Effekt ein. teste jetzt mal noch nach zeit.

              • Habe es jetzt hin und her probiert und auch verschiedene Einstellungen getestet aber es tritt immer wieder derselbe Effekt ein. Bei der Questauswahl nach xp. Der Bot wechselt irgendwann in den untätig Modus und macht gar nichts mehr. Der Button „Aktion manuell stoppen“ auf der Übersichtseite eines Chars wechselt in „Aktion manuell starten“ aber auch durch die Betätigung dieses Buttons läßt sich der bot nicht mehr zum laufen bringen. Das kuriose ist aber auch das er das nicht bei allen chars macht(Habe 10 Chars). Es ist aber auch immer ein anderer Char bei dem er problemlos durchläuft

                • habe festgestellt das wenn man die aktion manuell starten will reicht nicht ein klick auf den button, es müssen mindestens 3 klicks sein. desweiteren steht im log das er die Taverne betreten hat nach betätigen des aktions Buttons steht im log „Quest durch benutzer abgebrochen“ obwohl gar keine quest durchgeführt wird.

    • Inzwischen gibt es einen Thread zu dieser Thematik im Forum. Scheinbar tritt das Problem nur dann auf, wenn die Arena deaktiviert ist.

      Das Forum ist generell besser als die Kommentarfunktion geeignet, um komplexe Themen wie dieses zu behandeln 😉

      Viele Grüße,
      Olafson

  15. Also bei mir funktioniert das mit der SID nicht, da steht zwar wenn ich das genauso gemacht habe wie beschrieben, SID synchroniesiert! aber er loggt mich wenn er Taverne macht trozdem aus! was mache ich falsch?

    • Hallo Rene,
      an sich ist das Feature auch nur experimentell. Ich werde da nochmal nachdrehen 😉

      Grüße,
      Robin

  16. Hey Leute,
    ich habe für euch schon gespendet und bei meiner HWID Steht auch Spenderstatus: true.
    jedoch wenn ich die MFBot.exe öffne updatet sie nicht automatisch

    • Hallo Amon,
      wir hatten einige Probleme mit den Spenderversionen – um sicher zu gehen, solltest du diese Version nochmal manuell downloaden.

      Grüße,
      Robin

  17. city guard not working on some character (strange, similar settings as others). Keep „idle“ status and in log is „buying beer“ 🙂

      • Hi Monrgel, you are right, the bot should proceed with the next step in case that there are no mushrooms for the current activity. Thanks for the info!

        I guess this will be fixed soon 😉

        Best regards, Olafson

  18. Maybe you changed something in your network settings – so you have to send the ID of your (old) bot to Robin (I think it was him ^^). I had the same problem….

    Wenn ihr irgendetwas an eurer Netzwerkkonfiguration ändert, kann es sein, dass euer Bot eine andere ID bekommen hat. Die müsst ihr (wie bei der PayPal Zahlung) an Robin schicken (ich glaube er wars) und er schaltet euch wieder frei. So hatte es bei mir funktioniert….

    Da fällt mir ein Robin – das könnte ein Problem sein. Nehmen wir an die alten Bots laufen nicht mehr und die neuen Versionen kann man nicht starten – wie bekommt man dann die ID raus?

    • Die HWID, wird in die acc.ini geschrieben, sollte also auch so funktionieren^^…

      cheers L.

      • Gut zu wissen….als Info für alle bei denen sich der Bot nicht selbst updatet obwohl sie gespendet haben 🙂

  19. ??? ok kapiere nicht hab es downloadet aber hab nur eine MFBot.resources.dll datei bekommen was soll ich damit jetzt machen ??

    • Du hast nur die englische Sprachdatei gedownloaded.

      Der Download des Bots ist für Nicht-Spender erst möglich, wenn der Countdown abgelaufen ist.

      Möchtest du die aktuellste Version vorher downloaden, dann tue dem MFBot-Team etwas Gutes und Spende einen kleinen Geldbetrag(min. 2,50€) und erfreue dich vor allen anderen an der aktuellen Version 😉

  20. Ich starten Sie den Bot, indem ein Tag vorgeschlagen.

    Aber jetzt sagt er mir, dass die Version deppasser für 20 Tage. und zu versuchen, die Download-Version zu verwenden, ich lee gleiche Meldung

    • Alte Versionen laufen nach dem Release einer neuen Version nur noch 20 Tage. Danach muss man auf die aktuelle Version umsteigen, welche hier zum Download angeboten wird.

      Das Ganze erleichtert den Support des Bots, da man die Vielfalt der Versionen bei den Nutzern eindämmt.

      Dementsprechend bitte in 4 Tagen hier die aktuelle Version downloaden.

      • Genau einen Tag nach dem Spender, dem Start der Bot sagt mir, er für 20 Tage aus.

        Wie auch immer, werde ich 4 Tage warten, um die Wiederverwendung zu ermöglichen.

Comments are closed.