Magical Fidget Bot – Version 2.0.7.2

Guten Tag zusammen,

das letzte Update hat doch einige Bugs gehabt, darunter einen ziemlich schwerwiegenden Stadtwachen-Fehler. In der heutigen Version werden diese gefixt.

Changelog:

# Textfehler behoben
# Selbsttest der Benachrichtigungen korrigiert
# Gravierenden Fehler bei der Stadtwache behoben

Downloadlinks:

Und wie immer gilt: Um das Update zu “installieren”, die alte Datei einfach durch die neuere ersetzen. (Tipp: Acc.ini vorher sichern :))
Und auch sonst gilt wie immer, dass die in den Einstellungen ausgegrauten Funktionen noch nicht eingebaut sind und auch diese Version immer noch eine Beta-Version ist, was heißt, dass manche Funktionen entweder nicht oder fehlerhaft funktionieren könnten. In diesem Fall(, der eigentlich nicht eintreten sollte^^,) bitten wir euch, den Fehler in den Kommentaren oder in der Bug-Sektion des Forums zu posten 😉

Euer MFBot-Team

 

Sprachpaket Englisch / Speechpackage English

Download (Unzip the en.zip in the directory of the MFBot)

(*) Legende:
+ = Hinzugefügt
~ = Geändert
– = Entfernt
# = Bugfix

[PU_BotProgramupdate_Invisible]2.0.7.2[/PU]

28 thoughts on “Magical Fidget Bot – Version 2.0.7.2
  1. Hallo. 🙂
    Eben den Bot probiert: Interface und alles sieht ganz gut aus, jedoch kann ich ihn nicht benutzen, da beim Hinzufügen des Accounts diese Fehlermeldung erscheint:
    „Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attepmt to continue. If you click Quit, the application will close immediately.
    Array cannot be null“
    Name, Passwort, Land, Server wurde alles richtig eingestellt. Klicke ich auf Continue und auf „Ok“, kommt die gleiche Fehlermeldung. Klicke ich auf „Fertig stellen“, schließt sich das Fenster, jedoch ist der Account nicht vorhanden.

    Mit freundlichen Grüßen
    Lucas

    • Hallo Lucas,
      hast du das .NET Framework 4.5 installiert? Auf Windows 7 brauchst du das nämlich, da sonst Fehler unweigerlich auftreten werden 😉

      Grüße,
      Robin

  2. Hey, seit v2.072 (hab 2.071 nicht ausprobiert wegen des stadtwache bugs) geht er nicht mehr in den Turm, er sagt der cool down sei abgelaufen… geht aber dennoch nicht rein 🙁

    LG

      • hatte vielleicht nicht lang genug gewartet, ich glaube das problem war, dass das inventar voll war, und als ich es geleert hatte hab ich nur ca 20 min gewartet, in denen er nicht rein gegangen ist, bevor ich schlafen ging. (obwohl ich auf nen anderen acc geklickt hatte und wieder zurück, sodass er sich wieder auf den char einloggt, aber anscheinend kontrolliert er nicht dabei ob das inventar gemacht wurde,
        bzw wenn um 21:34 nicht in den turm gegangen wurde weil inventar voll, um 21:35 wird inventar geleert, wann versucht er den turm wieder? erst um 22:34, obwohl der cooldown auf 0 steht?

        lg

        • Hallo Licor,
          in der Tat prüft der Bot dies nur stündlich, weil es in einem normalen Fall nicht passieren würde, dass das Betreten zunächst nicht möglich ist, dann kurz danach aber schon. Daher wäre es unnötig, den Bot jede Minute auf einen abgelaufenen Cooldown zu prüfen.
          Grüße,
          Robin
          PS: Die „Verkaufe billigstes Item […]“-Funktion müsste dem vorbeugen – sie funktioniert in der nächsten Version auch wieder^^

  3. Moin moin,

    der Bot läuft super, tolle arbeit.

    Nur ’ne kleine Frage, ist es momentan möglich, dass er Stündlich arbeitet und dann 10 Stunden? Weil er will den bei mir 13 Stunden auf die Arbeit schicken das geht natürlich nicht….^^
    Hat da wer ne Lösung? 😛

    Gruß

      • Demnach ist aber nicht^^

        Außerdem: Der Bot verkauft keine Sachen im Log:
        [INFO-TAV] 19:02 Uhr: Taverne wird betreten…
        [WARN-TAV] 19:02 Uhr: Inventar ist voll! Bitte leeren oder in den Einstellungen die entsprechende Option setzen!

        Option ist auf billigsten Gegenstand verkaufen…

        • tränke und epics sind davon ausgeschlossen… aber ich glaube das problem ist hier bekannt, dass das nicht richtig funktioniert

          • Hallo Sixx, hallo Licor,
            das Problem wurde schon erkannt und wird im nächsten Update endgültig behoben.
            Allerdings kann ich den Stadtwachenfehler bei mir nicht nachvollziehen – welche Einstellungen hast du denn gemacht?

            Grüße,
            Robin

            • Huhu Robin,

              hatte sie erst auf 00:00:00-00:00:00 und dann 10h, da macht er halt nur bis 24Uhr.
              Gibt es eine Einstellung wo er immer direkt auf 10h schickt? Habe momentan 18Uhr bis 5 Uhr da schickt er erst um 19 Uhr auf Stadtwache, weil 11 Stunden ja nicht gehen^^

              Lg

              • Hallo sixx,
                ich hoffe inständig, den Fehler behoben zu haben. Bei mir klappt es jetzt allerdings – das Update erscheint spätestens heute Mittag 😉

                Grüße,
                Robin

  4. Hallo ihr lieben,
    wie immer tolle Arbeit!!

    Ich habe bei mir den Fehler das er mein Inventar immer voll haut und dann auf untätig geht. Ich habe alles so eingestellt das er alles verkaufen soll also Toilettel Artikel etc und auch bei Händler das er den billigsten Gegenstand verkaufen soll wenn Inventar voll aber macht er leider nicht 🙁

  5. Hallo Robin,
    ich hätte da noch eine Idee für den Bot.
    Währe es möglich einen Button hinzuzufügen der alle Charakter ein oder ausloggt und den Bot deaktiviert oder aktiviert.

  6. Leider ist das mit der Stadtwache nicht behoben.

    Die SW stellt sich immer selbst ein 🙁 Bitte wieder die v2.0.7 als Grundlage nehmen.

    Ich nutze den Bot um die ALU runter zubekommen und das die SW 10h läuft.

    • Hallo Schwede,
      könntest du „stellt sich immer selbst ein“ genauer erklären? Was stellt sich wo und wann selbst ein?

      Grüße,
      Robin

  7. super arbeit,
    musste heut aber leider feststellen, das unser pilzbug wieder da ist.
    hab bei allen accs eingestellt, das er 15 pilze aufheben soll, er hat aber alle verspielt 🙁
    bitte nochmal drüber schauen und beheben.
    ach und bitte das mit die tränke irgendwie lösen, kann mich mit die kleinen flaschen todschmeißen 😉

    lg

    • Hallo racere,
      das Problem mit den Pilzen dürfte eigentlich nicht auftreten, werde das nachprobieren und dir dann nochmalk Feedback geben.

      Grüße,
      Robin

  8. hammer arbeit, ABER
    nach update von 2.0.7 auf 2.0.7.2 kommt wieder diese
    mysteriöse fehler :zu wenig speicher blablabla

    habe vorher die acc.ini auf desktop kopiert
    2.0.7.2 gestartet die acc.ini ersetzt und es kam dieser fehler

    nachdem ich beide .ini gelöscht habe
    und die acc. händisch neu eingegeben habe ,
    kommt dieser fehler NICHT mehr

    wieso funkt. das mit acc.ini sichern (kopieren&ersetzen) nicht?

    hoffe damit geholfen zu haben 🙂

    • Hallo Tom,
      dann scheint etwas ziemlich gravierendes geändert worden zu sein, es ist natürlich schlecht, dass er dann abstürzt aber umso besser, dass es eine Lösung gibt 🙂

      Grüße,
      Robin

Comments are closed.