Error Core General Fehler auf dem Raspbery Pi

Antworten
Inaktiv
Beiträge: 12
Registriert: Do 26. Dez 2013, 01:28

Error Core General Fehler auf dem Raspbery Pi

Beitrag von Inaktiv » So 28. Jun 2020, 00:06

Hallo zusammen,

ich habe heute versucht den Bot auf meinem Raspberry Pi zu installieren. Bei starten kommt jedoch folgende Fehlermeldung.

27.06.2020 23:59:57 Error Core General
!##
!## at (wrapper managed-to-native) System.Threading.Thread.SleepInternal(int)
at System.Threading.Thread.Sleep (System.Int32 millisecondsTimeout) [0x00019] in <a6f810169ec746eeb2789b925e2858c0>:0
at de.mfbot.MFBot_NG.Basisbibliothek.Account.runBot () [0x00074] in <919407374df9421785e1f21fb76b20dd>:0
at de.mfbot.MFBot_NG.Basisbibliothek.PerformanceHelper+<>c__DisplayClass27_0.<createThread>b__0 () [0x00000] in <919407374df9421785e1f21fb76b20dd>:0
27.06.2020 23:59:57 Error Core General
!##
!## at (wrapper managed-to-native) System.Threading.Thread.SleepInternal(int)
at System.Threading.Thread.Sleep (System.Int32 millisecondsTimeout) [0x00019] in <a6f810169ec746eeb2789b925e2858c0>:0
at de.mfbot.MFBot_NG.Basisbibliothek.Account.runBot () [0x00074] in <919407374df9421785e1f21fb76b20dd>:0
at de.mfbot.MFBot_NG.Basisbibliothek.PerformanceHelper+<>c__DisplayClass27_0.<createThread>b__0 () [0x00000] in <919407374df9421785e1f21fb76b20dd>:0
27.06.2020 23:59:57 Error Core General
!##
!## at (wrapper managed-to-native) System.Threading.Thread.SleepInternal(int)
at System.Threading.Thread.Sleep (System.Int32 millisecondsTimeout) [0x00019] in <a6f810169ec746eeb2789b925e2858c0>:0
at de.mfbot.MFBot_NG.Basisbibliothek.Account.runBot () [0x00074] in <919407374df9421785e1f21fb76b20dd>:0
at de.mfbot.MFBot_NG.Basisbibliothek.PerformanceHelper+<>c__DisplayClass27_0.<createThread>b__0 () [0x00000] in <919407374df9421785e1f21fb76b20dd>:0
27.06.2020 23:59:57 Error Core General
!##
!## at (wrapper managed-to-native) System.Threading.Thread.SleepInternal(int)
at System.Threading.Thread.Sleep (System.Int32 millisecondsTimeout) [0x00019] in <a6f810169ec746eeb2789b925e2858c0>:0
at de.mfbot.MFBot_NG.Basisbibliothek.Account.runBot () [0x00074] in <919407374df9421785e1f21fb76b20dd>:0
at de.mfbot.MFBot_NG.Basisbibliothek.PerformanceHelper+<>c__DisplayClass27_0.<createThread>b__0 () [0x00000] in <919407374df9421785e1f21fb76b20dd>:0

Hat da jemand eine Lösung oder eine Idee wie man das Problem beheben kann?

Liebe Grüße

Benutzeravatar
TakeViagraDieHard
Spender
Beiträge: 122
Registriert: Fr 29. Jun 2018, 21:53
Wohnort: NRW
Hat sich bedankt: 13 Mal
Danksagung erhalten: 36 Mal

Re: Error Core General Fehler auf dem Raspbery Pi

Beitrag von TakeViagraDieHard » So 28. Jun 2020, 01:05

Hast du Mono wie folgt schon installiert?
Raspbian 10:

Code: Alles auswählen

sudo apt install apt-transport-https dirmngr gnupg ca-certificates
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/debian stable-raspbianbuster main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update
Raspbian 9:

Code: Alles auswählen

sudo apt install apt-transport-https dirmngr gnupg ca-certificates
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/debian stable-raspbianstretch main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update
Danach:

Code: Alles auswählen

sudo apt install referenceassemblies-pcl
sudo apt install ca-certificates-mono
sudo cert-sync
Quelle: https://www.mono-project.com/download/s ... n-raspbian

Inaktiv
Beiträge: 12
Registriert: Do 26. Dez 2013, 01:28

Re: Error Core General Fehler auf dem Raspbery Pi

Beitrag von Inaktiv » So 28. Jun 2020, 01:55

Danke für den Vorschlag, dass hatte ich noch nicht gemacht.
Habe es gerade nachgeholt aber der Fehler tritt trotzdem wieder auf.

Der Bot Logged sich ein aber danach tritt dieser fehler auf.

Grüße

Benutzeravatar
TakeViagraDieHard
Spender
Beiträge: 122
Registriert: Fr 29. Jun 2018, 21:53
Wohnort: NRW
Hat sich bedankt: 13 Mal
Danksagung erhalten: 36 Mal

Re: Error Core General Fehler auf dem Raspbery Pi

Beitrag von TakeViagraDieHard » So 28. Jun 2020, 02:30

Sind vielleicht noch die Berechtigungen falsch?

Den Pfad "/home/pi/mfbot" musst du nur auf den ändern, den du benutzt:

Code: Alles auswählen

sudo chmod a+x+r+w /home/pi/mfbot -R
sudo chown pi /home/pi/mfbot -R
sudo chgrp pi /home/pi/mfbot -R

Inaktiv
Beiträge: 12
Registriert: Do 26. Dez 2013, 01:28

Re: Error Core General Fehler auf dem Raspbery Pi

Beitrag von Inaktiv » So 28. Jun 2020, 19:45

Dass scheint das Problem gelöst zu haben.

Vielen lieben dank.

Inaktiv
Beiträge: 12
Registriert: Do 26. Dez 2013, 01:28

Re: Error Core General Fehler auf dem Raspbery Pi

Beitrag von Inaktiv » Di 30. Jun 2020, 00:59

Hey,
leider funktioniert es doch noch nicht.

Wieder die gleiche Fehlermeldung
Habe den Pi auch schonmal neu aufgesetzt und die von dir genannten schritte befolgt.

So sieht meine Ausgabe aus.
Bild
Ich habe "sudo ./MFBot_Konsole_ARMRasp" verscht und bekomme das gleiche Problem.

hast du vielleicht noch eine Idee?
Dateianhänge
mfbot.png
mfbot.png (33.73 KiB) 87 mal betrachtet

F0restbear
Beiträge: 852
Registriert: Mo 8. Jun 2015, 17:36
Hat sich bedankt: 27 Mal
Danksagung erhalten: 154 Mal

Re: Error Core General Fehler auf dem Raspbery Pi

Beitrag von F0restbear » Di 30. Jun 2020, 21:30

Huhu,

welchen Befehl hast du denn für die Berechtigung genutzt?
Viele Grüße / Best regards

F0restbear ()

Inaktiv
Beiträge: 12
Registriert: Do 26. Dez 2013, 01:28

Re: Error Core General Fehler auf dem Raspbery Pi

Beitrag von Inaktiv » Mi 1. Jul 2020, 14:24

TakeViagraDieHard hat geschrieben:
So 28. Jun 2020, 02:30
Sind vielleicht noch die Berechtigungen falsch?

Den Pfad "/home/pi/mfbot" musst du nur auf den ändern, den du benutzt:

Code: Alles auswählen

sudo chmod a+x+r+w /home/pi/mfbot -R
sudo chown pi /home/pi/mfbot -R
sudo chgrp pi /home/pi/mfbot -R
Diese hier habe ich ausgeführt aber den Pfad auf meinen Angepasst.
hast du dass gemeint?

F0restbear
Beiträge: 852
Registriert: Mo 8. Jun 2015, 17:36
Hat sich bedankt: 27 Mal
Danksagung erhalten: 154 Mal

Re: Error Core General Fehler auf dem Raspbery Pi

Beitrag von F0restbear » Mi 1. Jul 2020, 18:04

Genau, poste doch mal bitte den genauen Befehl, den du eingegeben hast. Spontan würde mir nämlich auch nichts einfallen, was den Error triggern könnte.
Viele Grüße / Best regards

F0restbear ()

Inaktiv
Beiträge: 12
Registriert: Do 26. Dez 2013, 01:28

Re: Error Core General Fehler auf dem Raspbery Pi

Beitrag von Inaktiv » Mi 1. Jul 2020, 20:49

Klar. Hier hast du einen auszug meiner History.
mfbot_berechtigungen.png
mfbot_berechtigungen.png (4.7 KiB) 52 mal betrachtet

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste