Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Antworten
skanthunt42
Beiträge: 19
Registriert: Mo 26. Sep 2016, 21:03
Hat sich bedankt: 4 Mal
Danksagung erhalten: 2 Mal

Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Beitrag von skanthunt42 » Mo 9. Sep 2019, 12:33

Hallo!

Ich melde mich aufgrund einer Fehlermeldung auf meinem Raspberry Pi 3. Ich hab mir die Neuste Version des Bots und eine neu erstellte Acc.ini (welche ebenfalls mit der neuen Version erstellt wurde) auf meinen Pi geladen und bekomme direkt beim Start des Programms die folgende Fehlermeldung.

Kann mir jemand sagen, wie ich den Fehler beheben kann?

Ich danke jetzt schon für eure Hilfe.

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'System.Console' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.ConsoleDriver' threw an exception. ---> System.Exception: Magic number is wrong: 542
at System.TermInfoReader.ReadHeader (System.Byte[] buffer, System.Int32& position) [0x00028] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.TermInfoReader..ctor (System.String term, System.String filename) [0x0005f] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.TermInfoDriver..ctor (System.String term) [0x00055] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.ConsoleDriver.CreateTermInfoDriver (System.String term) [0x00000] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.ConsoleDriver..cctor () [0x0004d] in <a6f810169ec746eeb2789b925e2858c0>:0
--- End of inner exception stack trace ---
at System.Console.SetupStreams (System.Text.Encoding inputEncoding, System.Text.Encoding outputEncoding) [0x00007] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.Console..cctor () [0x0008e] in <a6f810169ec746eeb2789b925e2858c0>:0
--- End of inner exception stack trace ---
at BasisFightSimulation.FightSimulationAssemblyLoader.Load () [0x00000] in <9d9de89a508144e1aaa63d671c34d983>:0
at de.mfbot.MFBot_NG.Konsole.Program.Main (System.String[] args) [0x00000] in <d2a283d6c0c74ec79a3f1c52e2b7f0c3>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'System.Console' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.ConsoleDriver' threw an exception. ---> System.Exception: Magic number is wrong: 542
at System.TermInfoReader.ReadHeader (System.Byte[] buffer, System.Int32& position) [0x00028] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.TermInfoReader..ctor (System.String term, System.String filename) [0x0005f] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.TermInfoDriver..ctor (System.String term) [0x00055] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.ConsoleDriver.CreateTermInfoDriver (System.String term) [0x00000] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.ConsoleDriver..cctor () [0x0004d] in <a6f810169ec746eeb2789b925e2858c0>:0
--- End of inner exception stack trace ---
at System.Console.SetupStreams (System.Text.Encoding inputEncoding, System.Text.Encoding outputEncoding) [0x00007] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.Console..cctor () [0x0008e] in <a6f810169ec746eeb2789b925e2858c0>:0
--- End of inner exception stack trace ---
at BasisFightSimulation.FightSimulationAssemblyLoader.Load () [0x00000] in <9d9de89a508144e1aaa63d671c34d983>:0
at de.mfbot.MFBot_NG.Konsole.Program.Main (System.String[] args) [0x00000] in <d2a283d6c0c74ec79a3f1c52e2b7f0c3>:0

Gesendet von meinem JSN-L21 mit Tapatalk


skanthunt42
Beiträge: 19
Registriert: Mo 26. Sep 2016, 21:03
Hat sich bedankt: 4 Mal
Danksagung erhalten: 2 Mal

Re: Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Beitrag von skanthunt42 » Sa 14. Sep 2019, 23:13

Hi,
Ich melde mich zu Wort, da ich noch keine Antwort bekommen habe.
Jetzt frag ich mich natürlich ob das Problem bei mir liegt. Hab ich den Post in die falsche Kategorie hochgeladen?

Gesendet von meinem JSN-L21 mit Tapatalk


F0restbear
Beiträge: 721
Registriert: Mo 8. Jun 2015, 17:36
Hat sich bedankt: 23 Mal
Danksagung erhalten: 139 Mal

Re: Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Beitrag von F0restbear » Sa 14. Sep 2019, 23:41

Hallo Skunt,

der Post ist in der richtigen Kategorie, jedoch gibt es in unserem Team genau 2 (aktive) Leute, die sich damit auskennen: Robin und Unknown. Und beide sind leider durch Urlaub/Prüfungen verhindert ^^

Ich bin absoluter Laie auf dem Gebiet, aber mein Lösungsvorschlag wäre: 1) Deinen Pi auf die neuste Version aktualisieren und 2) auf die Release Version zurückgreifen, da die Windows Version mit der neusten Beta bei einigen Nutzern auch nicht klar kommt, siehe viewtopic.php?f=20&t=2618

Sorry, dass ich nicht großartig weiterhelfen konnte, aber vielleicht funktioniert es ja
Viele Grüße / Best regards

F0restbear ()

skanthunt42
Beiträge: 19
Registriert: Mo 26. Sep 2016, 21:03
Hat sich bedankt: 4 Mal
Danksagung erhalten: 2 Mal

Re: Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Beitrag von skanthunt42 » So 15. Sep 2019, 09:40

F0restbear hat geschrieben:Hallo Skunt,

der Post ist in der richtigen Kategorie, jedoch gibt es in unserem Team genau 2 (aktive) Leute, die sich damit auskennen: Robin und Unknown. Und beide sind leider durch Urlaub/Prüfungen verhindert ^^

Ich bin absoluter Laie auf dem Gebiet, aber mein Lösungsvorschlag wäre: 1) Deinen Pi auf die neuste Version aktualisieren und 2) auf die Release Version zurückgreifen, da die Windows Version mit der neusten Beta bei einigen Nutzern auch nicht klar kommt, siehe viewtopic.php?f=20&t=2618

Sorry, dass ich nicht großartig weiterhelfen konnte, aber vielleicht funktioniert es ja
Hi,
kein Problem, danke für deine Hilfe. Werde deine Ratschläge befolgen und melde mich wieder.

Gesendet von meinem JSN-L21 mit Tapatalk


skanthunt42
Beiträge: 19
Registriert: Mo 26. Sep 2016, 21:03
Hat sich bedankt: 4 Mal
Danksagung erhalten: 2 Mal

Re: Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Beitrag von skanthunt42 » Mo 23. Sep 2019, 20:31

Hallo,

wie versprochen melde ich mich wieder. Leider haben die vorher genannten Tipps noch nicht geholfen.
Hat noch jemand eine Idee wie ich dieses Problem umgehen kann?

Gesendet von meinem JSN-L21 mit Tapatalk


UnknownDeveloper
Core Developer
Beiträge: 392
Registriert: Sa 19. Mai 2018, 15:59
Hat sich bedankt: 22 Mal
Danksagung erhalten: 82 Mal

Re: Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Beitrag von UnknownDeveloper » Mo 23. Sep 2019, 21:17

Hi,

bitte mit der neuen Beata (sollte heute oder die Tage kommen) nochmal probieren ;-)

skanthunt42
Beiträge: 19
Registriert: Mo 26. Sep 2016, 21:03
Hat sich bedankt: 4 Mal
Danksagung erhalten: 2 Mal

Re: Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Beitrag von skanthunt42 » Mo 23. Sep 2019, 21:19

UnknownDeveloper hat geschrieben:Hi,

bitte mit der neuen Beata (sollte heute oder die Tage kommen) nochmal probieren ;-)
Werde ich machen. Danke für deine schnelle Antwort. :)

Gesendet von meinem JSN-L21 mit Tapatalk


skanthunt42
Beiträge: 19
Registriert: Mo 26. Sep 2016, 21:03
Hat sich bedankt: 4 Mal
Danksagung erhalten: 2 Mal

Re: Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Beitrag von skanthunt42 » Di 1. Okt 2019, 21:23

Hallo,

Leider hält die Fehlermeldung noch immer an. Hab meinen Raspberry Pi schon neu aufgesetzt und immer noch die gleiche Fehlermeldung.
Die Acc.ini erstelle ich auf einen virtuellen PC auf dem Windows läuft, kann das zu diesem Problem führen?

Würde mich über eure Hilfe freuen.

ohoschix
Beiträge: 1
Registriert: Mi 30. Okt 2019, 13:59

Re: Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Beitrag von ohoschix » Mi 30. Okt 2019, 14:02

Schau mal hier rein, das hat bei mir geholfen. Es scheint ein Issue der Mono Runtime zu sein.

https://stackoverflow.com/questions/492 ... -wrong-542

Gib mal im Terminal:
export TERM=xterm

ein, dannach startest Du den BOT

Viele Gruesse
Ohoschix

skanthunt42
Beiträge: 19
Registriert: Mo 26. Sep 2016, 21:03
Hat sich bedankt: 4 Mal
Danksagung erhalten: 2 Mal

Re: Raspberry Pi Fehlermeldung: 'Unhandled Exception'

Beitrag von skanthunt42 » Mi 30. Okt 2019, 14:10

ohoschix hat geschrieben:Schau mal hier rein, das hat bei mir geholfen. Es scheint ein Issue der Mono Runtime zu sein.

https://stackoverflow.com/questions/492 ... -wrong-542

Gib mal im Terminal:
export TERM=xterm

ein, dannach startest Du den BOT

Viele Gruesse
Ohoschix
Hi,
Dürfte wirklich ein Bug bei Mono sein. Hat das Problem gelöst, vielen Dank für deine Hilfe.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast