Error in PetRequirements

In das Unterforum "Erledigt" werden alle Beiträge geschoben, die erledigt sind, bspw. bei behobenen Bugs.
Antworten
Kukielka
Beiträge: 3
Registriert: Do 26. Apr 2018, 11:56

Error in PetRequirements

Beitrag von Kukielka » Mo 4. Feb 2019, 09:47

Hey!
Ich bekomme relativ häufig folgenden Fehler beim Verwenden des Linux Buildes.

Code: Alles auswählen

20190203 23:28:39 Error Core Object reference not set to an instance of an object

Message: Object reference not set to an instance of an object
HResult: -2147467261
Source: Basisbibliothek
StackTrace: at de.mfbot.MFBot_NG.Basisbibliothek.Pets.PetRequirements.isGuildStrongEnough () [0x0000b] in <12649f79f6bd45abbb146d7bc04c9d2a>:0
at de.mfbot.MFBot_NG.Basisbibliothek.Pets.PetRequirements.situationMet (System.DateTime dT) [0x00085] in <12649f79f6bd45abbb146d7bc04c9d2a>:0
at de.mfbot.MFBot_NG.Basisbibliothek.Pets.PetRequirements.requirementsMet (System.DateTime dT, de.mfbot.MFBot_NG.Basisbibliothek.QuestLocation loc) [0x0003d] in <12649f79f6bd45abbb146d7bc04c9d2a>:0
at de.mfbot.MFBot_NG.Basisbibliothek.Pet.requirementsMet (de.mfbot.MFBot_NG.Basisbibliothek.QuestLocation loc, System.DateTime questFinish) [0x00012] in <12649f79f6bd45abbb146d7bc04c9d2a>:0
at de.mfbot.MFBot_NG.Basisbibliothek.TavernTasker+<>c__DisplayClass2_3.<startQuest>b__30 (de.mfbot.MFBot_NG.Basisbibliothek.Pet p) [0x00019] in <12649f79f6bd45abbb146d7bc04c9d2a>:0
at System.Linq.Enumerable+WhereEnumerableIterator`1[TSource].MoveNext () [0x00037] in <abeb153532fb46718501a600866a8d76>:0
at System.Linq.Enumerable.Any[TSource] (System.Collections.Generic.IEnumerable`1[T] source) [0x00015] in <abeb153532fb46718501a600866a8d76>:0
at de.mfbot.MFBot_NG.Basisbibliothek.TavernTasker.startQuest () [0x009b2] in <12649f79f6bd45abbb146d7bc04c9d2a>:0
at de.mfbot.MFBot_NG.Basisbibliothek.TavernTasker.doTavern () [0x008b2] in <12649f79f6bd45abbb146d7bc04c9d2a>:0
at de.mfbot.MFBot_NG.Basisbibliothek.Account.<doBot>g__runner|346_0 (System.Action act) [0x0001a] in <12649f79f6bd45abbb146d7bc04c9d2a>:0
at de.mfbot.MFBot_NG.Basisbibliothek.Account.doBot () [0x004c3] in <12649f79f6bd45abbb146d7bc04c9d2a>:0
at de.mfbot.MFBot_NG.Basisbibliothek.Account.runAllBots () [0x00056] in <12649f79f6bd45abbb146d7bc04c9d2a>:0
TargetSite: Boolean isGuildStrongEnough()
Der Fehler führt den Bot nicht zum Absturz oder ähnliches, jedoch spammt er die Logs zu (und wahrscheinlich wird ja irgendetwas nicht gehen).
Jedoch ist es nichts offensichtliches.

Grüße!
Zuletzt geändert von Robin am So 17. Feb 2019, 12:47, insgesamt 1-mal geändert.
Grund: Titel angepasst

Benutzeravatar
Robin
Administrator
Beiträge: 1387
Registriert: So 30. Jun 2013, 18:12
Wohnort: Rheinland-Pfalz
Hat sich bedankt: 207 Mal
Danksagung erhalten: 170 Mal

Re: Error Docker

Beitrag von Robin » So 17. Feb 2019, 12:47

Hi Kukielka,
das war ein Fehler der nicht direkt mit der Art des Builds zutun hatte, sondern generell einfach ein Bug im Bot.
Sollte in der neuesten Version behoben sein.

Grüße,
Robin
MFBot 3.x: 19858 CodeZeilen in 32 Dateien
MFBot 4.x: 79792 CodeZeilen in 234 Dateien
MFBot 5.x: 62804 CodeZeilen in 331 Dateien

Antworten

Wer ist online?

Mitglieder in diesem Forum: Ahrefs [Bot], Bing [Bot] und 0 Gäste